crooner
Last Activity:
Aug 16, 2017 at 10:08 AM
Joined:
Apr 17, 2004
Messages:
4,058
Likes Received:
140
Trophy Points:
63
Gender:
Male
Birthday:
Dec 15, 1970 (Age: 46)
Location:
San Diego, CA
Occupation:
Electronics Technician

Share This Page

crooner

Tube Marantzed, Male, 46, from San Diego, CA

crooner was last seen:
Aug 16, 2017 at 10:08 AM
    1. Randy Kling
      Randy Kling
      Standard Thanks
      1. crooner likes this.
    2. SidSmith
      SidSmith
      Hello Crooner, I congratulate you for you're Marantz system and you dedicated passion to restore these piece of history. I nearly read all of your subject, from you're 8B restoration to the acquisition of your two model 9 last year.

      Continue your good work !
      1. crooner likes this.
      2. crooner
        crooner
        Thank you!
        Nov 11, 2015
    3. Solder_Slinger
      Solder_Slinger
      Hi Crooner,

      Have a Marantz 7, S/N 13544 that has a bad balance control. Was noisy, while in shop getting the phono section repaired, they sprayed it with cleaner and now it doesn't function, believe the wiper got fried.

      Any suggestions on how to replace it? I see in an earlier post you recommended using an Allen Bradley J type, believe this should be 1 meg linear.

      Regards,

      -Ed
    4. flemo
      flemo
      Hi Crooner,

      You seem to have a good knowledge of Accuphase amps ans wondered if you knew where I could source some replacement transistors for a 1986 E-205? I have a pic of the damaged items but not sure I can attach it to this message.

      Cheers

      Peter (flemo).
    5. bingQ
      bingQ
      I agree.I've got an Audio Research Classic 60 and Quicksilver Silver 60 Monoblocks but for reasons,I guess,only Marantz owners understand I keep using the old Marantz.Maybe it's the sound I remember.Of course,the 7C that came with it probably has a lot to do with that.
    6. bingQ
      bingQ
      Hi Crooner! Love your avatar! I've got an 8B too!
    7. bmc1987
      bmc1987
      Hi crooner, I found an old thread that you were in that involved a pioneer sx 850. I have one here that is acting up. What was wrong with the one you had/have when you replaced the transistors and resistors? Thanks.
    8. socioloco
      socioloco
      Hola Crooner, vi un post donde seguías paso a paso la restauración de un 8b.Tengo por aquí un Amplificador Integrado Cayin A-50 que dice ser una copia, o mas bién un fusil del 8b, sabes algo se eso?
    9. D.E.K
      D.E.K
      Hi Nestor, btw I got your name from hifi_nut's message who added you as a friend. Now the reason I messaged you...

      I accidentall stumbled upon one of your old old threads about a Pioner SX-850 with no relay engaging or audio output. I have an SX-1010 that has the exact symptoms. In your last post, you said you were going to replace the regulator transistors on the power supply board. I was wondering how that turned out. I'dreally appreciate if you share the experience. Thanks a lot and Merry Christmas.

      Des
    10. hifi_nut
      hifi_nut
      Hiya Nestor, glad you´ll have me as your friend.
  • Loading...
  • Loading...
  • About

    Gender:
    Male
    Birthday:
    Dec 15, 1970 (Age: 46)
    Location:
    San Diego, CA
    Occupation:
    Electronics Technician
    Vintage Marantz Vacuum Tube enthusiast. Also interested in shortwave radio, and music in general with preference to Jazz, Classical and classic Pop/Rock.

    Signature

    [​IMG]
    1963 Marantz Model 7, 1962 Marantz Model 9's, 1964 Marantz Model 10 with 1978 Chartwell 15 ohm LS3/5A's