1. Time for some upgrades in server hardware and software to enhance security and take AK to the next level. Please contribute what you can to sales@audiokarma.org at PayPal.com - Thanks from the AK Team
    Dismiss Notice

Admiral Hi-Fidelity Console Stereo

Discussion in 'Tube Audio' started by IowaFightFan, Nov 20, 2018.

  1. IowaFightFan

    IowaFightFan New Member

    Messages:
    41
    I just got an Admiral Hi-Fidelity Console Stereo the other day .it's got great sound, deep bass with the 15" woofer. It does have a few issues though.

    The tuner needle will not go past a certain point. In the picture, you see the black marker line, near the number "12" on the AM side. The tuner needle stops at that point for some reason. Any ideas what causes that and if it's easily fixable?

    The turntable has some issues too, but I'm confident I can get that going.
     

    Attached Files:

     

    Please register to disable this ad.

  2. Dave451

    Dave451 AK Subscriber Subscriber

    Messages:
    1,172
    Location:
    Philly area
    The dial cord has probably slipped or the pointer is hanging up for some reason. You'll have to get into it and have a look, but the fix will be mechanical so if you can handle the turntable, you can handle this. If you can find an owners or service manual, they often have dial cord stringing and adjustment instructions. And, like I always say, there's pretty much a Youtube video for everything. Good luck with it--nice looking unit!
     
    Pio1980 and IowaFightFan like this.
  3. IowaFightFan

    IowaFightFan New Member

    Messages:
    41
    Thank you for information! I do not have a service manual yet, but believe it or not the original manuals and advertising material was still in the cabinet.
     
  4. gadget73

    gadget73 junk junkie Subscriber

    Messages:
    36,979
    Location:
    Southern NJ
    Do radio stations seem to be about at the right place on the dial? If they aren't, the cord likely slipped. If they are, its probably something jamming. I've even seen incorrectly installed dial strings that bind up and cause this sort of issue.
     
    IowaFightFan likes this.
  5. IowaFightFan

    IowaFightFan New Member

    Messages:
    41
    Yes, the stations that do come in seem to be in the correct location on the dial. I appreciate the information though.
     
  6. IowaFightFan

    IowaFightFan New Member

    Messages:
    41
    So, I am still messing with this stereo. It did appear that the cord had binded up a bit. I got it straightened out, but now the radio stations are no longer in sync with the needle. What is the best way to remedy this? Simply move the needle on the cord into the correct position?

    It also does not appear that the tuning eye tube is working properly. It powers on and is bright enough, but the "shadows" in the tube don't move at all as you tune the radio.
     

     

    Please register to disable this ad.

  7. gadget73

    gadget73 junk junkie Subscriber

    Messages:
    36,979
    Location:
    Southern NJ
    The pointer has to be mechanically right first. usually the dial is set so its at the lowest mark on the dial but you can also just set it to a known station and move the pointer accordingly, then confirm it looks right at the extreme ends of travel.
     
    IowaFightFan likes this.
  8. Tom Bavis

    Tom Bavis Audiophool Subscriber

    Messages:
    9,026
    Location:
    Macedon NY
    If you can find a model or chassis number, I may have service info.
     
    IowaFightFan likes this.
  9. IowaFightFan

    IowaFightFan New Member

    Messages:
    41
    Its marked as Model # 413
     
  10. IowaFightFan

    IowaFightFan New Member

    Messages:
    41
     
  11. IowaFightFan

    IowaFightFan New Member

    Messages:
    41
    413 is on the back of the console as well.
     

    Attached Files:

     

    Please register to disable this ad.

  12. Tom Bavis

    Tom Bavis Audiophool Subscriber

    Messages:
    9,026
    Location:
    Macedon NY
    Sams Photofact folder 401-1, from 1958. The good news is that I probably have it, bad news is that I have no working scanner since "upgrading" my computer.
     
    safebet and IowaFightFan like this.
  13. IowaFightFan

    IowaFightFan New Member

    Messages:
    41
    Can it be sent as a PDF via email maybe?
     
  14. s-petersen

    s-petersen Scott Subscriber

    Messages:
    4,662
    Location:
    Middletown,New York
    I hate those "upgrades"
     
  15. Selmerdave

    Selmerdave Well-Known Member

    Messages:
    817
    If you have a smart phone, scanning apps work remarkably well.
     
    IowaFightFan likes this.
  16. IowaFightFan

    IowaFightFan New Member

    Messages:
    41
    What "upgrades" are you referring to?
     

     

    Please register to disable this ad.

  17. IowaFightFan

    IowaFightFan New Member

    Messages:
    41
    Yeah, I use CamScanner for work all of the time. It's free and works great.
     
  18. Dswankey

    Dswankey Super Member

    Messages:
    3,820
     
    IowaFightFan likes this.
  19. IowaFightFan

    IowaFightFan New Member

    Messages:
    41
    Haha, I got'cha. I thought you were referring to the stereo I was working on. I was thinking that I haven't upgraded anything on it....lol
     
  20. s-petersen

    s-petersen Scott Subscriber

    Messages:
    4,662
    Location:
    Middletown,New York
    Many devices lost support Win 7 to Win 10
     

Share This Page