1. Time for some upgrades in server hardware and software to enhance security and take AK to the next level. Please contribute what you can to sales@audiokarma.org at PayPal.com - Thanks from the AK Team
    Dismiss Notice

Ashly FTX-1501 III - intermittent channel

Discussion in 'Solid State' started by EngineerNate, Nov 9, 2018.

  1. EngineerNate

    EngineerNate AK Subscriber Subscriber

    Messages:
    3,129
    Picked this up for under a Benjamin as this lineup of amps piqued my interest. It was sold as "won't power on."

    I pretty quickly discovered the root cause of that condition:
    [​IMG]

    I was able to find a fuse holder from an Ashly EQ at full compass that looked identical and it in fact was, so I simply stole the cap from it. Ordered a few fuses from s digikey with another order (10A MDA slow blow) and fired it up on the DBT.

    It passed the DBT test perfectly. Initial surge, then a dim glow. Came out of protect right away. I checked for DC on the outputs and measured none.

    I hooked up a source and tried it out. Got sound from one channel only. Switched it on and off again... Clean and clear sound in both speakers, for about 30 seconds then the same channel dropped out. This behavior was repeatable.

    I'm thinking a bad protection relay contact as power cycling flips the relay, giving temporary sound. I didn't wait long enough in the cycle for a temperature change to be the cause and there was no percussive maintenance involved, so a loose connection or cracked solder joint seems unlikely. Thoughts? Replies here will be rewarded with amp nudes. :naughty::D

    Cheers,
    Nathan
     

     

    Please register to disable this ad.

  2. EngineerNate

    EngineerNate AK Subscriber Subscriber

    Messages:
    3,129
    Definitely a bad relay or loose connection. Percussive maintenance successful brings the channel back.
     

Share This Page