Help me with a blown diode please, SX-1500TD

Discussion in 'Pioneer Audio' started by ranukic, Aug 15, 2017.

  1. ranukic

    ranukic Member

    Messages:
    82
    Thanks!
     
  2. ranukic

    ranukic Member

    Messages:
    82
    Check this out. My Head Amp Unit is p/n W21-001 but your manual has a W15-049. Strange stuff!
     
  3. petehall347

    petehall347 the brandy coffee man

    Messages:
    23,312
    Location:
    uk.. the middle bit
  4. petehall347

    petehall347 the brandy coffee man

    Messages:
    23,312
    Location:
    uk.. the middle bit
    i have 3 manuals here . all a bit different
    head amp is w21-001 in first one i posted . you read it wrong
    sx990 is W15-049
     
    Last edited: Sep 9, 2017
  5. ranukic

    ranukic Member

    Messages:
    82
    Gotcha! Thanks again
     
  6. gadget73

    gadget73 junk junkie Subscriber

    Messages:
    32,365
    Location:
    Southern NJ
    I pretty much went through this with my Allied 495. Its mostly an SX-1500TD, using the head amp from an SX-990 and the older MPX board that you have. The recap list I came up with is here, you'll have to figure what goes in your head amp and mic amp though.


    "hiccups" in Allied 495 (Pioneer) FM tuner

    I used UF5408 diodes in mine. It had 2 originals and 2 non-original. Both crossed to a 3 amp part, so I used the UF5408 that I had on hand as those are also 3 amp.
     
  7. larryderouin

    larryderouin Do I get Food, Med's, or more gear this Month? Subscriber

    Messages:
    19,774
    Location:
    Glen Burnie Md.
  8. ranukic

    ranukic Member

    Messages:
    82
    Thank you
     

Share This Page