Kenwood Basic M2

Discussion in 'Kenwood-Trio/Kensonic-Accuphase' started by Cody AOC, Sep 7, 2017.

  1. Cody AOC

    Cody AOC Member

    Messages:
    92
    Hi so recently I bought a Kenwood Basic M2 amplifier off someone for $5 yes it does work but it does not have the 2 prong power entry connector. Somebody took it off and it's not anywhere but I can't seem to find a replacement for it this is one of the units that has a voltage selector on the back right under where the power cord should be so when I brought it home I had to solder a cord on it to test it works like new little dusty but can always be cleaned so if anyone can provide me a link to somewhere that i can buy this power entry connector but as a 2 prong version since i tried using a regular 3 prong power entry connector and it did not fit it was too big to fit.
     
  2. jeffe

    jeffe AK Subscriber Subscriber

    Messages:
    1,331
    Location:
    McKinney, TX
  3. jeffe

    jeffe AK Subscriber Subscriber

    Messages:
    1,331
    Location:
    McKinney, TX
  4. Cody AOC

    Cody AOC Member

    Messages:
    92
  5. johnebravo

    johnebravo I should be practicing

    Messages:
    1,092
    Location:
    Syracuse, NY
  6. Cody AOC

    Cody AOC Member

    Messages:
    92
  7. hopjohn

    hopjohn Kenwood Krazy Subscriber

    Messages:
    890
    Location:
    Dallas, TX
    Would this work? Midway down this page, on the right side.
    [​IMG]
     
  8. Cody AOC

    Cody AOC Member

    Messages:
    92
    It could work if it's the same size or really close to the original size of the plugin
     
  9. Redone90

    Redone90 New Member

    Messages:
    10
    Location:
    Melbourne Australia
    Go to the DRM Audio page and email Daniel to get his PDF catalog.
    http://www.drmaudio.com
    You can get a modern 3 pin plug and lead with a template to set it up for $15.
    Well worth the $$$
    Good luck
     

Share This Page