kr 6600 dial cord

Discussion in 'Kenwood-Trio/Kensonic-Accuphase' started by David De, May 26, 2018.

  1. David De

    David De New Member

    Messages:
    2
    Hey folks, I was putting new lights in my 6600 & the darn dial cord came undone. Many hours later, I mean many hours, it looks like it is strung real real close. However, after testing, I have very poor fm reception. Can anyone help......thanks
     

     

    Please register to disable this ad.

  2. Blue Shadow

    Blue Shadow I gotta get me a new title

    Messages:
    20,775
    Location:
    SE PA
    Dial string just moves the indicator and the tuning capacitor. I think you should clean the tuning cap per dr*audio's instructions on the tuner forum and see if that helps.

    Did you follow the manual to restring or just get the string that was there back close enough?
     
  3. David De

    David De New Member

    Messages:
    2
    I used the same string and got it real close, the dialer moves up and down the board. I don't think it needs to be cleaned, it was working fine before this happened
     
  4. bisonguy

    bisonguy Active Member

    Messages:
    225
    Location:
    Ottawa, Canada
    KR-6600 dial cord.JPG Other than the indicator being in the wrong position the dial cord should have no impact on fm reception. Is the tuning capacitor going full travel each way. Here is an image of the procedure for stringing the KR-6600. I actually have a KR-6600 as well.
     
  5. Blue Shadow

    Blue Shadow I gotta get me a new title

    Messages:
    20,775
    Location:
    SE PA
    If you are sure that all this messing around inside the unit did not let any smoke, dirt, dust, corrosion or any sort of junk get into the tuning capacitor maybe cleaning isn't necessary but remember an electron is at least 6 orders of magnitude smaller than the smallest of any of the above.

    Could be some bumped adjustments but resetting those is part of a tuner alignment and not a DIY without lots of equipment, training and experience. Most techs don't do tuner alignments.

    Hope you get it fixed right.
     

Share This Page