Nad 705 repair

Discussion in 'Solid State' started by Eastham, Jan 23, 2018.

  1. Eastham

    Eastham More Class-A than ever!

    Messages:
    2,052
    Location:
    Liverpool, UK
    So. My first Nad. Symptoms; no display and no sound but it comes out of protection.

    [​IMG]

    Elechickens tape all over the place and the broken clips on the LCD backlight board tells me she ain't no virgin. The Cash Converters sticker doesn't help either. Atleast I seem to have been spared Nads black glue...

    [​IMG]

    Given the problem affects both channels I started measuring the power supply voltages come to find I'm missing the +15v that feeds the LCD backlight lamps and the pre amps, that explains both my issues. A quick look at IC301 shows some cracked solder joints, touched them up and hey presto! We got sound! but only on one channel from headphones.

    Gettting to the solder joints for IC301 requred me to just remove the entire chassis and rotate it out of the way. Yeah... Okay Nad....

    [​IMG]

    Moving onto the no sound from one channel of the headphones. I decided to disassemble and remove the front panel to clean it. At first I thought it was this cracked joint which I touched up.

    [​IMG]

    But quickly found out that the leg of one of the resistors hadn't been solderd been soldered in. The lack of solder on the leg and no signs of it being cut or resoldered lead me to believe it left the factory like this!

    [​IMG]

    Guess the guys in the QC dept where having an offday. I touched up a few more bad solder joints around some high heat components and the input jacks and set it up in my system.

    [​IMG]

    All in all I like this receiver. I can certainly say it has a very soft and laid back sound with pretty good bass response. Compared to my SX-737 which sounds pretty bright.
     
    E.Man, eizner23 and teal'c like this.

     

    Please register to disable this ad.

  2. Eastham

    Eastham More Class-A than ever!

    Messages:
    2,052
    Location:
    Liverpool, UK
    Another update!

    I had some 10-15v 55ma axial lamps laying around and decided to try them in the backlight. Good news, they work! Bad news, the screen the segments where almost impossible to see, like the screen had no contrast. So after reflowing the controller chip, and the display solder joints I noticed something. If I moved the two pin power cable the digits would show up. So I resoldered both ends of the cable and voila, a working LCD. Only bummer is the missing segment on the band section. Not sure if that's my doing re flowing the IC or it's something to do with the LCD itself. Either way I'm happy to have it working. Trying to guess what input I was on before hand was a literal shot in the dark.

    [​IMG]
     
    kjello likes this.
  3. NAD80

    NAD80 Super Member

    Messages:
    2,135
    Location:
    Carlisle PA
    Nice fix on the 705. Sometimes QC just does a selection of units to check instead of doing all the units. I would check all the solder joints on the unit. And take a look at the caps. Have a 1300 to repair found some bad caps.
     
    Last edited: Jan 23, 2018
  4. Eastham

    Eastham More Class-A than ever!

    Messages:
    2,052
    Location:
    Liverpool, UK
    Thanks. I'm waiting on my new ESR meter to be delivered. As soon as it gets here I'll definetely be checking caps. I re flowed most if not all solder joints that have any liability to be cracked or stressed. I guess bad joints are a common thng with Nads. Seeing as the headphone board was never fixed I'm guessing none of the previous owners used headphones which is weird considering it was once pawned at Cash Converters and presumably sold to someone else then again I did buy it from a E-waste center so maybe the issue with the display and headphones is how it came to be in said E-waste center. Came shipped to me in a Sansui AU-2200 box too which is pretty neat, still had the original foam in it too. Guess I have a box for a Sansui AU-2200 if I ever come across one. Good luck on your repairs!
     
  5. NAD80

    NAD80 Super Member

    Messages:
    2,135
    Location:
    Carlisle PA
    Thank you. Like Nad units. Have a 3140 integrated amp, 4020 tuner. The tuner needs recapped. A cap in the tuner pulled itself off the lead while checking the value in the PCB. It's time to replace them.
     
  6. Eastham

    Eastham More Class-A than ever!

    Messages:
    2,052
    Location:
    Liverpool, UK
    I can't wait to get more then I can play with my Nads... (I'm sorry I had too..) I'm really enjoying my NAD I must admit, it really holds it's own especially playing power metal. Fast paced drumming and shredding guitars along with vocals and it just takes it all in it's stride without showing any signs of loosing power. I always wanted the chance the hear the so called Nad sound. So when this receiver poped up on eBay I figured why not. Glad I bought it. It's on par if not a better than my SX-737 which to my ears is the most detailed amp in my collection so far. Part of me wants to grab a Matching CD player. Something like the 502 which I think was sold with this receiver. Not sure if I can cheat on my beloved SL-P2 though. And I hate when caps do that. when you're trying to move them out the way or something and the the can just pulls off one of the legs.
     

     

    Please register to disable this ad.

  7. NAD80

    NAD80 Super Member

    Messages:
    2,135
    Location:
    Carlisle PA
    The 3140 rated for 40W, but sounds more like 80W. The Nad units always had good amount of headroom. Have a philips CD-60 cd player, sounds great. Yard sale player. As for guitars and drums, I really like Five Finger Death Punch.
     
    E.Man likes this.
  8. Eastham

    Eastham More Class-A than ever!

    Messages:
    2,052
    Location:
    Liverpool, UK
    Nad's have that strange soft clipping that allows them to output more power than they can constantly deliver by smoothing the clipping. Pretty coold idea if you ask me. That CD 60 looks like an absolute tank! I'll be keeping my eyes peeled for one. I haven't listened to Five Finger Death Punch in a while, I should add a few albums to my playlist. I've been mostly listening to albums I had when I was a edgy teen. Mostly Dragonforce, Avenged Sevenfold and Iron Maiden.
     
    Last edited: Jan 23, 2018
  9. E.Man

    E.Man Super Member

    Messages:
    1,203
    Location:
    Bega Valley, Australia
    Typical Nad of the time. Sound fine but the solder sux.
    My second system is a 3240 amp with 4020 tuner and 502 CD PLAYER.
     
    Eastham likes this.
  10. NAD80

    NAD80 Super Member

    Messages:
    2,135
    Location:
    Carlisle PA
    Into Pink Floyd, Golden Earring, Planet P Project, Metallica, FFDP, David Gilmour, Ultravox, Tangerine Dream, ELP, Jethro Tull. What I grew up on. Maybe a Nad of the time, but love the way it sounds.
     
  11. Eastham

    Eastham More Class-A than ever!

    Messages:
    2,052
    Location:
    Liverpool, UK
    My dad was into the heavier side of things, Def leppard, Judas Priest, Meatloaf, Deep Purple, ZZ-Top, Iron maiden, System of a down, Rainbow, Dio, etc. And my Granddad was into the softer kinda rock, The beatles, Motown, ABBA, Roxy music, ELO. I grew up around it all. I listen to most of the current top 10's in the car but the lack of guitars, drums and bass quickly bores me. Apart from the times I find a decent Classic rock station or a station decides to put something like the Foo Fighters on.
     

     

    Please register to disable this ad.

  12. NAD80

    NAD80 Super Member

    Messages:
    2,135
    Location:
    Carlisle PA
    They love the Marantz version CD-60, the phillips version is the same unit. The TDA1541A DAC. Its hard to find a good rock station. Real rare. So I go back to listening what I liked. Only have maybe 2 stations around here. My dad liked Pink Floyd, opera, country. So I listen to a lot of stuff.
     
  13. Eastham

    Eastham More Class-A than ever!

    Messages:
    2,052
    Location:
    Liverpool, UK
    We got two around me too, Radio City 2 and BBC Radio 2 (though Radio 2 don't always play classic rock.) Sadly not many people share my taste in music and don't want to listen to "old porno music" or "evil devil music". But we all have our own special tastes.
     
  14. NAD80

    NAD80 Super Member

    Messages:
    2,135
    Location:
    Carlisle PA
    Caught a documentary a while back, "When Albums Ruled The World" really enjoyed it. But the BBC screwed the audio on the You Tube version that was uploaded.
     
  15. Eastham

    Eastham More Class-A than ever!

    Messages:
    2,052
    Location:
    Liverpool, UK
    Sounds like an interesting watch. Might be something good to get settled into bed later. Currently fighting with my 705 trying to set the station presets.
     
  16. NAD80

    NAD80 Super Member

    Messages:
    2,135
    Location:
    Carlisle PA
    Hopefully it will remember what you set. If not look for a backup battery or a "supercap" to hold the presets in memory. The BBC always did have a way with documentaries, Remember "Connections" first series.
     

     

    Please register to disable this ad.

  17. Eastham

    Eastham More Class-A than ever!

    Messages:
    2,052
    Location:
    Liverpool, UK
    I still have no idea how to set them lol, I set them how the manual says but it seems to forget what I set immediately. Something to look into tomorrow, or well later on today in my case...
     
  18. NAD80

    NAD80 Super Member

    Messages:
    2,135
    Location:
    Carlisle PA
    Last edited: Jan 23, 2018
  19. Eastham

    Eastham More Class-A than ever!

    Messages:
    2,052
    Location:
    Liverpool, UK
    It might not be saving presets due to the fact I don't have an antenna hooked up as I don't have any antennas with the type of connector this has, it's like a smaller tv antenna jack. I tried to jury rig a antenna but all I got was one bar on the signal bar. No sound though. Think I'm gonna hit the hay too, it's quite late here.
     
  20. Freddymac2

    Freddymac2 Super Member

    Messages:
    1,784
    Antenna has nothing to do with saving presets. Change the battery or super cap!
     

Share This Page