Need help setting DC Offset

Discussion in 'Exclusively Sansui' started by z-adamson, Feb 1, 2019.

  1. z-adamson

    z-adamson Super Member

    Messages:
    1,827
    Device: Sansui Z7000

    Problem: Following the SM instructions, with 8ohm dummy loads connected, measuring and adjusting for +25vdc and -25VDC at pins 9 and 10 of the STK3106 module, all is well with the -25vdc adjustment. However, the +25VDC adjustment is not going so well in that I get 19.8VDC and as I adjust the variable resistor in pursuit of the 25VDC, the voltage reading does not change. No matter where I have the variable resistor set, the test point at the STK3106 is fixed at 19.8VDC. And no I am not probing the wrong test point. It is as though the VR has turned into a fixed resistor. So I measured ohms at the VR solder pads and it does change as I turn the VR. I also tried two different new STK3106 modules.

    Now, it is also worth noting that the SM states that once these adjustments are made, you are to measure DC voltage at the speaker binding posts and you should see 0 MVDC plus or minus 200 MVDC. I get 30mvdc on one and 50mvdc on the other. This suggests that I am good to go because it is within tolerance. But I am still irritated that the circuit does not respond to the VR and that I have 19.8VDC where I should have 25VDC.

    All the electrolytic caps, variable resistors, relays and the STK are new.

    What to do....?
     

     

    Please register to disable this ad.

  2. Robisme

    Robisme Sansui Enthusiast Subscriber

    Messages:
    11,901
    Location:
    Martinez California
    I would start by checking the voltage drop on the two zener diodes. Also check that new caps associated with those pins are installed with the correct polarity.
    Check the two resistors too.

    Maybe check for solder bridges or cold solder joints.

    Rob
     
    smurfer77 likes this.
  3. z-adamson

    z-adamson Super Member

    Messages:
    1,827
    Caps are good, -25vdc across each zener (pos lead of meter on one leg, neg lead on the other), soldering looks good, haven't pulled resistors to measure them....won't want to do that without new ones to put in.
     
    Last edited: Feb 2, 2019
  4. z-adamson

    z-adamson Super Member

    Messages:
    1,827
    Been running it at idle for a while now. Running rather steady. But still, an unadjustable 19.5 volts dc where I should have 25vdc. Hmmmm 15491349983031846387520.jpg 1549135052030-95842804.jpg 1549135086874-252342794.jpg 1549135110562-2116496371.jpg
     
  5. sregor

    sregor AK Subscriber Subscriber

    Messages:
    3,677
    Location:
    Mass
    Going by z7000x SM (z7000 not available at Hifiengine) but uses same STK driver IC and has the same 25 volts at the pins, but the parts list shows kZD1 as 24 volt Zener and kZD2 as 27 volt Zener...
    (I am not that familiar with amp so all advice should be taken with grain of salt)
     
  6. z-adamson

    z-adamson Super Member

    Messages:
    1,827
    Got it figured out.

    I had the variable resistor installed improperly....oops. Put another one in with the leads at the appropriate solder pads and good to go.
     
    smurfer77 likes this.

     

    Please register to disable this ad.

Share This Page