1. Time for some upgrades in server hardware and software to enhance security and take AK to the next level. Please contribute what you can to sales@audiokarma.org at PayPal.com - Thanks from the AK Team
    Dismiss Notice

New KR 7600

Discussion in 'Kenwood-Trio/Kensonic-Accuphase' started by rossm, May 14, 2018.

  1. rossm

    rossm AK Subscriber Subscriber

    Messages:
    256
    Hi
    Just found an old KR-7600 at a yard sale, it cleaned up pretty nice, but will need attention as the relay does not click. A HEAVY Well built unit, will look nice next to the KA-9100 if I ever finish it. I just downloaded the Service Manual and it looks like the voltages on the amplifier schematic are marked out. Any one know why ?
    thanks
     

     

    Please register to disable this ad.

  2. rossm

    rossm AK Subscriber Subscriber

    Messages:
    256
  3. sregor

    sregor AK Subscriber Subscriber

    Messages:
    3,492
    Location:
    Mass
    The scan was done in black and white. The voltages are highlighted in color (Orange, IIRC) and when scanned come out gray and are fairly unreadable).
     
  4. eiraved

    eiraved AK Subscriber Subscriber

    Messages:
    2,221
    Location:
    Antelope Valley, CA
    Great find! I believe those units have internal fuses, have you checked those? Many threads on repairing these, with a few having relay issues similar to yours.
     
    Last edited: May 15, 2018
  5. rossm

    rossm AK Subscriber Subscriber

    Messages:
    256
    That’s a bummer would have been really nice to have that info for troubleshooting
    Thanks for clearing that up !
     
  6. rossm

    rossm AK Subscriber Subscriber

    Messages:
    256
    Yes I have, haven’t had much time for it yet, other than cleaning it up and firing up on the variac and dim bulb. Looks like the + - B voltages are ok. Will post back when I find out more. Still need to get the KA 9100 finished and off the bench
     

     

    Please register to disable this ad.

Share This Page