1. Time for some upgrades in server hardware and software to enhance security and take AK to the next level. Please contribute what you can to sales@audiokarma.org at PayPal.com - Thanks from the AK Team
    Dismiss Notice

No power to phono section of Fisher 500C?

Discussion in 'Fisher' started by Mikeorg, Oct 2, 2018.

  1. nj pheonix

    nj pheonix AK Subscriber Subscriber

    Messages:
    9,827
    Location:
    New Jersey
    Listen to Dave, Mike .
    I have been where you are.
    I believed what i stated but I found my method or recording was wrong .
    It happens.:thumbsup:
     
    baconbadge and Mikeorg like this.

     

    Please register to disable this ad.

  2. Mikeorg

    Mikeorg New Member

    Messages:
    42
    Location:
    OREGON
    OK "WE" you and me got the 12AX7's glowing, turned out it was ether a cold solder on V16 or V17 or a dirty pin or loos pin's~I tightened all of them~!!! Thanks I'm going to check voltage and see where we are. Thanks Again! Oh not to mention a bad tube :dunno:
     
    Last edited: Oct 5, 2018
    I LIKE MUSIC and baconbadge like this.
  3. dcgillespie

    dcgillespie Fisher SA-100 Clone Subscriber

    Messages:
    9,673
    Location:
    Ball Ground, GA
    So glad you found it Mike! And, welcome to the wacky world of troubleshooting, where even the simplest of problems can be so evasive to solve. When the puzzle pieces don't fit, always assume nothing, and go back and recheck everything. It's the shortest path to getting the issue resolved.

    Congrats!

    Dave
     
  4. audmod01

    audmod01 Super Member

    Messages:
    1,219
    Location:
    Tioga, TX
    Kudos on your success. It is surprising how often we can misinterpret what we are observing. Sometimes it helps to let it rest a while before going back to recheck.

    Joe
     
    baconbadge likes this.

Share This Page