Pioneer sa-9800 output issue

Discussion in 'Pioneer Audio' started by jeffV, Jul 11, 2018.

  1. jeffV

    jeffV Active Member

    Messages:
    128
    Ok guys, I need help.
    I picked up a 9800 that has an output issue, very little output. I took it to a local tech, and he has had it for two months now, and he says the cause of the issue "escapes him" ...ugh...

    He says it is showing excessive voltage on the output section, he says there should be no voltage, but he is showing something like 70 volts on the output side?
    I am going to go pick the unit up as I now have no confidence in his diagnostic abilities.

    does anyone here want to jump in this one? I really want this thing fixed, or i may just sell it as a parts unit?
     

     

    Please register to disable this ad.

  2. petehall347

    petehall347 the brandy coffee man Subscriber

    Messages:
    26,241
    Location:
    uk.. the middle bit
    70 volts shouldn't be possible .. max it can be is 55v .
     
  3. slimecity

    slimecity Super Member

    Messages:
    2,592
    Location:
    New Zealand
    Pick it up and we will try to run through some things. The fact he is measuring voltage on the output suggests that at least, your speaker relay is engaging!
     
  4. petehall347

    petehall347 the brandy coffee man Subscriber

    Messages:
    26,241
    Location:
    uk.. the middle bit
    most likely be 70mv .. not 70 volts ..
     
  5. jeffV

    jeffV Active Member

    Messages:
    128
    ok, he said it is 52 volts. The amp was working when I took it to him, but it had an audible hum, and the sound output was extremely low. I will be picking it up tomorrow.
    please stand by...

    thanks
     

Share This Page