1. Time for some upgrades in server hardware and software to enhance security and take AK to the next level. Please contribute what you can to sales@audiokarma.org at PayPal.com - Thanks from the AK Team
    Dismiss Notice

Pure Ipod Dock Issue

Discussion in 'Digital Sources' started by moviemusic, Jun 20, 2018.

  1. moviemusic

    moviemusic AK Subscriber Subscriber

    Messages:
    78
    Location:
    Seattle, WA
    I have a Pure i20 Ipod dock hooked into my bedroom system, which I love. Unfortunately, it seems to have developed a problem where it will intermittently cut out. It's very unpredictable, but it seems to happen most often after it's been playing a while.

    I've swapped out all the other components in the system, and pretty much confirmed it's the dock. My question is: are there any kind of options out there for repair, or am I just out of luck? :( Trying to find a good-quality replacement dock these days seems to be difficult ....
     

     

    Please register to disable this ad.

  2. jblnut

    jblnut Don't Overthink It Subscriber

    Messages:
    2,377
    Location:
    Boston Area
    analog out or digital? maybe switch to the other and see if the issue goes away?

    jblnut
     
  3. moviemusic

    moviemusic AK Subscriber Subscriber

    Messages:
    78
    Location:
    Seattle, WA
    That's a good suggestion--and about the only thing I haven't tried so far. Neither of my amps has a coaxial in, so I've ordered a converter--here's hoping it works. Thanks!
     
  4. jblnut

    jblnut Don't Overthink It Subscriber

    Messages:
    2,377
    Location:
    Boston Area
    NP - mine is still working (fingers crossed) and I sold my spare so when it's gone, that's it.

    jblnut
     
  5. olson_jr

    olson_jr AK Subscriber Subscriber

    Messages:
    13,673
    Location:
    Pilgrim Hills Michigan
    Have you tried cleaning the connector with a little Deoxit? My wife used to use a similar dock and the connector was a PIA to keep clean and working.

    I bought her an HTR iStreamer to use with her iPods and have never had a connection issue since.
     
  6. Leebob

    Leebob A Man In The Crowd Subscriber

    Messages:
    8,704
    Location:
    NorCal
    I've an i20 still going strong. Have had trouble with the Ipod classic. Might check to see if your hd is the problem. I've had mine playing a song and in the middle switch to another song by a different artist:dunno:.
     

     

    Please register to disable this ad.

  7. moviemusic

    moviemusic AK Subscriber Subscriber

    Messages:
    78
    Location:
    Seattle, WA
    Welp, I got a digital to analog converter AND new digital coaxial cable, hoping that would correct the issue ... and last night, the dang thing starts cutting out again.

    At this point, I'm pretty sure it's the dock--I've listened to my Ipod (it's a 4th gen touch) on headphones and on a different Apple dock (also plugged into an amp) with absolutely no problems. I've also swapped out RCA cables and transferred the Pure dock to a different amp and had the exact same problem reoccur, so I'm pretty sure it's not my amp either.

    I may have to try the Deoxit and see if that helps--though I'm not holding my breath, given that the dock cuts out regardless of what connections I am using. I welcome any additional suggestions, though!
     
  8. Goldie99

    Goldie99 Well-Known Member

    Messages:
    771
    Location:
    The original Boston, UK
    Try checking the (30) individual dock connection terminals - repeated insertion / removal can 'bend' them to the point that they no longer make good contact.

    I've had similar connectors that displayed somewhat analogous problems, but that worked perfectly again after treating them to some Deoxit, and 'tweaking' the various contact terminals using a small sharply pointed pin (under magnification).
     
    moviemusic likes this.
  9. moviemusic

    moviemusic AK Subscriber Subscriber

    Messages:
    78
    Location:
    Seattle, WA
    Well, I took a good look at the dock and noticed that the plastic housing around the dock connector had cracked/was loose. One careful application of electrical tape and some deoxit later, the problem seems to have disappeared. Here's hoping it stays that way!

    Thanks to everyone for the advice!
     
  10. rebellovw

    rebellovw Super Member

    Messages:
    2,982
    Location:
    Prescott, AZ
    Great devices - mine is still going strong - I'd be highly bummed to lose it.
     

Share This Page