Questions on a MX-110 restore

Discussion in 'McIntosh Audio' started by analog addict, Apr 29, 2018.

  1. analog addict

    analog addict Glory or Death!

    Messages:
    9,116
    Location:
    Central NC - RDU
    Friend of mine has commissioned a restore on a "barn find" unit. IIRC, these square top IF filters and such mean that this is the non-z unit. I've only restored a 110z. Any major differences between the two units? Any particular helpful hints for this specific unit?

    [​IMG]Untitled by Analog Addict, on Flickr

    [​IMG]Untitled by Analog Addict, on Flickr

    [​IMG]Untitled by Analog Addict, on Flickr

    Chrome definitely has some pitting under all the dirt. Wonder how much moisture this has seen? Guess I'll find out when I flip it over and remove the bottom plate.
     

     

    Please register to disable this ad.

  2. mnmmt

    mnmmt AK Subscriber Subscriber

    Messages:
    133
    Location:
    Minnesota
    That is a z. It looks like the discriminator transformer st the back corner is an updated one, which is good news. It actually will look good after several hours of cleaning. Be very careful with the lettering, as missing chassis lettering is impossible to fix. Those rocker switches do look ugly though.

    All the electrolytics and bumblebees need replacing. On mine I replaced all the ceramic disc caps in the signal path and on the 6d10 with polypropylene, and wow did it improve clarity and imaging! I plan to get fresh tubes and an alignment and then enjoy the fm.
     
  3. analog addict

    analog addict Glory or Death!

    Messages:
    9,116
    Location:
    Central NC - RDU
  4. dshoaf

    dshoaf That high voltage buzz

    Messages:
    10,105
    Location:
    Santa Cruz, CA
    That's a later revision of the Z series, AA, but not the last run of them. The dual/concentric adjustment pot on the chassis isn't there. There was a service bulleting issued on that. I've got those around here somewhere. Outside of the pitting, it certainly is all-original.

    Nice to see the front panel is free from lettering being rubbed off. Watch out for that inner glass panel with the FM scale and lettering on it. That stuff was water soluble and will likely almost fall off if you touch it. Ask me how I know that!

    Hope all is well out there in NC!

    Cheers,

    David
     
  5. analog addict

    analog addict Glory or Death!

    Messages:
    9,116
    Location:
    Central NC - RDU
    When you coming to visit Dave? I need to look for that thread where you detailed a lot of the stuff that needed to be done during my first Z restore. I did that restore at my old house, and I've been the "new" one for over 7 years.
    I'm not sure how much if any of the cosmetic restore I'm going to do, since that wasn't part of the deal. My gut feeling is that this wasn't used much, due to the pristine nature of the lettering and all the OEM toobs as well....
     
  6. Tangent

    Tangent Sweet nightmares!

    Messages:
    1,688
    Location:
    Ontario, Canada
    That's irreplaceable, isn't it?
     

     

    Please register to disable this ad.

  7. dshoaf

    dshoaf That high voltage buzz

    Messages:
    10,105
    Location:
    Santa Cruz, CA
    RadioDaze, at one time, carried a small stock. There were 3 versions of the inner glass which makes it hard to reproduce in small quantities. Check with them.

    Cheers,

    David
     
  8. dshoaf

    dshoaf That high voltage buzz

    Messages:
    10,105
    Location:
    Santa Cruz, CA
    Need to spend some more time out there, too, AA. On the restore, agreed, focus on getting it singing first. They sound great whether or not the chrome is pitted.

    Cheers,

    David
     
  9. nolasally

    nolasally AK Subscriber Subscriber

    Messages:
    5,297
    Location:
    RDU North Carolina
    I have a MX-110M coming from CA. to NC next week. I need your mailing address AA. PM please...
     
  10. analog addict

    analog addict Glory or Death!

    Messages:
    9,116
    Location:
    Central NC - RDU
    PM sent
     
  11. bakes

    bakes Super Member

    Messages:
    1,359
    Location:
    latham, NY
    Following this one with a lot of interest. Obviously. :beerchug::music:
     

     

    Please register to disable this ad.

  12. analog addict

    analog addict Glory or Death!

    Messages:
    9,116
    Location:
    Central NC - RDU
  13. analog addict

    analog addict Glory or Death!

    Messages:
    9,116
    Location:
    Central NC - RDU
  14. mnmmt

    mnmmt AK Subscriber Subscriber

    Messages:
    133
    Location:
    Minnesota
    If you think of it next time you are working on them, what voltages are you getting on your restored unit? Esp. The filament caps at the back and the 83v and 108v supplies. Mine are running quite high.
     
  15. analog addict

    analog addict Glory or Death!

    Messages:
    9,116
    Location:
    Central NC - RDU
    You might want to measure the voltage coming out of your power transformer if you haven't. I have two of these units, and the power transformer burnt out in one of them. May just be a coincidence, but it also might be worth your time to double check. The good thing is that you can get the PT rewound...
     
  16. mnmmt

    mnmmt AK Subscriber Subscriber

    Messages:
    133
    Location:
    Minnesota
    They are 10-15% over spec. My 83v is at 100v. The weirdest part is that I am getting 18v difference across the floated filament can at the back(the can is floated from the 83v source, and the filaments should be 12.6v above that, but I am getting 18v above, I believe). I will double check everything in the filament can hook up again. Plays and runs fine.
     

     

    Please register to disable this ad.

  17. analog addict

    analog addict Glory or Death!

    Messages:
    9,116
    Location:
    Central NC - RDU
    If not already done, one thing you can easily do is put a thermistor in the AC line in. If you look at my restored 110, you'll see the CL 70 coming off the fuse holder. This will give you a small amount of voltage drop on the wall voltage value. Sometimes, I'll put a thermistor on both sides of the AC line to double the voltage drop. This will also give you the benefit of a slow start/voltage ramp up, especially nice since you don't have a tube rectifier. You could always use clip leads to temporarily add one in order to take measurements...
     
  18. mnmmt

    mnmmt AK Subscriber Subscriber

    Messages:
    133
    Location:
    Minnesota
    I added one to the hot side of the primary input (i replaced the cord with a polarized 2 prong cord) but may add one to the neutral side too. I have some dropping resistors on the way to try to bring down both of the hv supplies. That shouldn't affect the filament windings if i drop the voltages down on the hv supplies , correct?
     
  19. mnmmt

    mnmmt AK Subscriber Subscriber

    Messages:
    133
    Location:
    Minnesota
    Now that i think of it, i should measure the filament voltage to the filament can--when i got it the 2.2 ohm sand block resistor was blown, likely due to that cap failing. I hope that didn't roast the filament winding, causing higher voltage. It is supposed to be 6.3v per orange wire with the white center tapped, if i recall correctly.
     
  20. analog addict

    analog addict Glory or Death!

    Messages:
    9,116
    Location:
    Central NC - RDU
    If your filament winding was affected, more than likely it would be toast, with no voltage forthcoming. Power supplies are not rocket science. What does the R154 resistor measure now? You could always up the value of that resistor slightly if you wanted to. But checking back on an old thread, my voltages ran high as well...

    http://audiokarma.org/forums/index.php?threads/recap-parts-list-for-an-mx-110-z.190149/page-5

    I asked Terry DeWickt about it at the time, and he didn't seem to think it was a problem. I would prolly deal with the filament voltages though...
     

Share This Page