Sherwood RV-5030R keeps shutting off.

Discussion in 'Solid State' started by Tarenteller, Jan 30, 2018.

  1. Tarenteller

    Tarenteller New Member

    Messages:
    47
    Location:
    San Francisco, CA
    Hi there--

    A friend of mine has a Sherwood RV-5030R receiver that has worked well until yesterday. The receiver shuts off after about 5 seconds. It's not in an overly warm environment and it has airflow around. I tried pulling the speaker wire, and then all connections. Also sprayed some canned air inside but it was not overly dusty. Tried switching power outlets, no change.

    I suppose it needs to be serviced (not by me, I'm no electronics tech). Trying to figure if this thing would be worth it.

    Any ideas what might be wrong with this thing? Thanks!!
     

     

    Please register to disable this ad.

  2. orsen

    orsen just another old cheapskate that likes audio Subscriber

    that unit has fuses in it ... use a multimeter to check them
    as far as paying for repair ... i wouldnt
     
  3. NAD80

    NAD80 Super Member

    Messages:
    2,135
    Location:
    Carlisle PA
  4. petehall347

    petehall347 the brandy coffee man Subscriber

    Messages:
    26,834
    Location:
    uk.. the middle bit
    if you hear it click when it comes on and goes off try disconnecting everything apart from mains cable and see if one click or 2
     
  5. Tarenteller

    Tarenteller New Member

    Messages:
    47
    Location:
    San Francisco, CA
    Hi all--

    Thanks for the replies! And thank you much for the manual NAD80. I bet it is a fuse blowing-- it does make a muted click on shut off.
     
  6. Tarenteller

    Tarenteller New Member

    Messages:
    47
    Location:
    San Francisco, CA
    Decided it wasn't worth fixing after I turned up a Sony STR-D1015 at a thrift store for $20. It'll do for now.
     

     

    Please register to disable this ad.

Share This Page