Yamaha CR 820 popping noise

Discussion in 'Yamaha' started by DavidinNC, May 15, 2018.

  1. DavidinNC

    DavidinNC Member

    Messages:
    66
    hey all,

    I have a CR-820, we recently moved from NC to FL. The movers packed the equipment, when I set it up tonight all I get are loud popping noises, very steady and rhythmic like a metronome. I’m worried something has been damaged. Anyone have any idea what that may be? The speakers make the popping noise even with the volume at zero. Feeling bummed..
     

     

    Please register to disable this ad.

  2. mbz

    mbz AK Subscriber Subscriber

    Messages:
    1,762
    Location:
    Melbourne, Victoria
    Maybe a bad solder joint/capacitor charging up then discharging. Google dry solder joint for pix, will probably need a magnifying lamp or similiar to spot them.
    Easy to fix, just relfow...
     
  3. DavidinNC

    DavidinNC Member

    Messages:
    66
    Thanks I’ll take a look!
     
  4. Blue Shadow

    Blue Shadow I gotta get me a new title

    Messages:
    19,720
    Location:
    SE PA
    Even at zero volume means it is after the volume control, power amp maybe.
     
  5. avionic

    avionic " Black Knights " Subscriber

    Messages:
    39,969
    Location:
    Fort Dodge, Iowa
    Both channels ?
     
  6. Tim64

    Tim64 Super Member

    Messages:
    1,002
    Location:
    North Central West Coast
    Check for that corrosive glue I had a Yammie A-500 80's model and it would pop now and again and the glue was eating a few parts plus it's conductive.
     

     

    Please register to disable this ad.

  7. DavidinNC

    DavidinNC Member

    Messages:
    66
    Not sure I’ll have to check that. I’ve got my CR-1020 in getting the power supply rebuilt. Will have to see to the 820 after getting the 1020 back.
     

Share This Page